Формула с функцией ЕСЛИ

Формула проверки с использованием функции ЕСЛИ

Одна из наиболее часто используемых функций (категория: "Логические") это функция ЕСЛИ.

С ее помощью можно получить какое-либо значение в зависимости от того выполняется ли заданное условие или выполняется. Считается, что знание функции "ЕСЛИ" уже свидетельствует об определенном (не нулевом) уровне навыков в Excel.

Для лучшего понимания приведем синтаксис функции ЕСЛИ()

=ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

Итак, у этой функции три части (они разделены точкой с запятой):

  1. условие (в синтаксисе называется "логическое_выражение");
  2. то, что должно быть, если условие выполняется (значение, если истина);
  3. то, что посчитает формула, если условие не выполняется (значение, если ложь).

Если Вам интересно как написать формулу в Excel, то читайте дальше. Мы кратко, но доступно рассмотрим функцию ЕСЛИ() и приведем пример с объяснениями как работает эта функция.

Допустим, у нас есть данные о средней оценке по пятибальной шкале по итогам окончания школы расположенные в диапазоне B2:B7

4,5

4,8

4,2

3,9

3,7

4,7

Необходимо напротив каждого значения (в соседней ячейке - в столбце C) определить хорошист или троечник. Для этих целей как раз подойдет функция ЕСЛИ в сочетании с оператором сравнения (напомним, что операторы сравнения в Excel это знаки "больше", "меньше", "равно" и вариации с ними).

Сформулируем условие, которое будет реализовываться в формуле с использованием функции ЕСЛИ(): если значение ячейки больше 4, то формула должна дать в результате вычислений слово "хорошист", в противном случае – "троечник" (примечание: мы намеренно не рассматриваем варианты "двоечник" или "отличник" так как в нашем ряду чисел нет таких значений).

Итак, формула с функцией ЕСЛИ для решения нашей задачи:

=ЕСЛИ(B2>4;"хорошист";"троечник")

Чтобы получить результат по всему ряду данных (средних баллов) введем формулу в ячейку C2 и растянем ее вниз. После этого у нас появится диапазон с однотипными формулами, которые "посчитали" и определили (принято говорить "вернули") как выполняется заданное условие.

Далее приведены данные двух столбцов – столбца B, который содержит оценки, и столбца C, в котором формула с использованием ЕСЛИ определила нам степень успеваемости учащегося.

4,5          хорошист

4,8          хорошист

4,2          хорошист

3,9          троечник

3,7          троечник

4,7          хорошист

Очевидно, что поставленная цель достигнута. Функция ЕСЛИ сделала именно то, что нам было изначально необходимо.

 В этой небольшой заметке мы кратко рассмотрели основной принцип работы функции ЕСЛИ. Надеемся, что прочитавший заметку получил общее представление о том, как написать простую формулу с ЕСЛИ().

Материал приведен здесь лишь в ознакомительных целях и не раскрывает в полной мере тему использования функции ЕСЛИ() в экономических и прочих расчетах.

Хотелось бы подчеркнуть, что в действительности, использование этой функции настолько многообразно, что по одной этой функции ЕСЛИ() можно написать небольшую книгу.

Более продвинутый уровень – это использование функции ЕСЛИ() в сочетании с другими логическими (и не только) функциями, а также множественная вложенность функции ЕСЛИ() в сложной формуле с большим количеством условий.

 Сайт ExcelSkype – удаленное комплексное обучение Excel, написание, разработка и разъяснение формул Excel. Обращайтесь и Вы обязательно решите свои проблемы и задачи в Excel - страница КОНТАКТЫ 

В закладки: постоянная ссылка.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *