Формула массива в Excel что это

Формула массива в Excel

Этот сайт создан для тех, кто серьезно заинтересован в обучении Excel (уровни от начинающего до продвинутого) или просто хочет получить консультации о том, как сделать что-либо в Excel. Изучение и консультирование происходит по Skype дистанционно. Далее в ознакомительных целях приведена краткая информация о формулах массива Excel и отличии их от других (обычных, "немассивных") формул.

На этой странице кратко о том, что такое формула массива (формулы массивов) в Excel.

Информация приводится в сжатой форме. Цель – дать общее представление о том, чем формула массива отличается от обычных формул в Excel.

Первое, что нужно знать: формула массива вводится не так, как обычная формула.

Для того, чтобы ввести формулу массива необходимо нажать одновременно три клавиши Ctrl+Shift+Enter

Визуальным признаком формулы массива (после того, как она введена) являются фигурные скобки { } которыми "обрамляется" формула.

Пример: {=СУММ((E81:E94>2500)*(F81:F94))}

Нужно понимать, что Excel сам проставить открывающую и закрывающую фигурную скобку в начале и в конце формулы. Если Вы захотите ввести их самостоятельно, то после завершения ввода формулы, которую Вы поместите внутрь фигурных скобок введя их вручную, Excel будет воспринимать такое выражение просто как текст.

Теперь если Вы видите, что в комментарии к формуле сказано, что это - формула массива, скопируйте ее, вставьте на лист Excel, при необходимости отредактируйте и введите формулу одновременным нажатием на Ctrl Shift Enter

Дальше можно не читать, так как далее приводится перечень вопросов связанных с формулами массивов:

Как ввести формулу массива

Какие свойства имеет формула массива

Что нужно знать, чтобы написать (создать) формулу массива

Какие бывают виды формул массива

Почему иногда необходимо вводить формулу массива сразу во все ячейки диапазона

В каких случаях применяется формула массива

Какие самые востребованные формулы массива

Какие есть ограничения при использовании формул массива

Какие функции нельзя применять в формулах массива

 

Ответы на эти вопросы могут быть интересны тем, кто хотел бы перейти на новый уровень освоения программы Excel.

 Если Вы заинтересованы в том, чтобы научиться свободно использовать формулы в Excel и, в частности, формулы массива, обращайтесь через сайт excelskype, чтобы пройти обучение "премудростям" Excel. Обучение адаптируется именно под Ваши потребности и задачи, которые Вы решаете в excel и проводится дистанционно через Skype.Время обучения необходимо согласовывать заранее.

Есть вопросы по обучению Excel удаленно? 

В закладки: постоянная ссылка.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *