Как формулой Excel округлить число

Как формулой Excel округлить число

В первых двух заметках из серии "1 формула в день" мы привели формулы, в которых использовали функции из категорий "Дата и время" и "Текстовые" (о категориях функций – см. внизу страницы)

А сейчас рассмотрим одну полезную формулу, которая будет реализована функцией из категории "Математические".

 Формула, позволяющая округлять числовое значение до нужного числа разрядов

=ОКРУГЛ(B2;1)

Формула работает очень просто. Она округляет число в указанной ячейке (в нашем случае – это ячейка B2) до 1 знака после запятой. То есть, если ячейка B2 содержит число 12,43977, то в результате работы формулы мы получим число 12,4

Синтаксис этой формулы: ОКРУГЛ(число;число_разрядов)

Как видно, в нашем примере мы указали число разрядов равное единице, таким образом, мы как бы сказали формуле, что хотим, чтобы после запятой после округления остался только один знак.

Округление чисел – одна из востребованных операций в Excel. Кроме функции ОКРУГЛ в Excel есть еще 7 функций, которые предназначены для округления чисел (различные варианты округления вверх, округления вниз, а также округление до целого кратного заданному числу).

 Подробнее о том, как использовать функции округления Вы можете узнать, обратившись к нам через страницу КОНТАКТЫ или оставив комментарий внизу этой страницы.Профессиональная помощь и обучение Excel удаленно – цель нашего ресурса Excel по Skype. Иногда достаточно всего одного-двух занятий, чтобы в десятки раз упростить Вашу работу в Excel. 
Мастер функций в Excel

Внешний вид окна "Мастер функций" в Excel

Формулы в Excel обычно включают в себя одну или несколько функций, а функции в Excel делятся на такие категории: "Финансовые", "Дата и время", "Математические", "Статистические", "Ссылки и массивы", "Работа с базой данных", "Текстовые", "Логические", "Проверка свойств и значений", "Инженерные", "Аналитические", "Совместимость". На скриншоте показано "Окно мастера функций Excel", там можно увидеть перечень категорий функций.

В закладки: постоянная ссылка.

2 Comments

  1. Николай

    Внимание! При округлении чисел, например: 1,4445 до второго знака после запятой, вернет 1,44, а не 1,45 (1,4445 -> 1,445 -> 1,45)
    P.S. Проверял как в Excel 2007, так и в 2016

  2. Да, все верно, в справке об этом косвенно есть информация.

    Формула
    =ОКРУГЛ(2,149; 1)

    Описание
    Округляет число 2,149 до одного дробного разряда

    Результат
    2,1

    Попробуем сформулировать правило по которому функция ОКРУГЛ() производит округление чисел:
    - если после того знака, до которого мы хотим округлить идет число меньше 5, то мы его не учитываем, если больше или равно, то увеличиваем на 1 единицу соответствующего разряда

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *